RPC Degraded
Resolved
Apr 15 at 11:56am PDT
Degraded performance for RPC requests (server-side errors and latency spikes) across the supported chains in the EU regions is now resolved. Thank you for your patience!
Affected services
Ethereum
Polygon
Avalanche
Binance
Ethereum Sepolia
Polygon Amoy Testnet
Optimism Sepolia
Arbitrum
Avalanche Fuji
Binance Testnet
Arbitrum Sepolia
Updated
Apr 15 at 11:56am PDT
All services have been restored.
Affected services
Ethereum
Polygon
Avalanche
Binance
Ethereum Sepolia
Polygon Amoy Testnet
Optimism Sepolia
Arbitrum
Avalanche Fuji
Binance Testnet
Arbitrum Sepolia
Created
Apr 15 at 08:50am PDT
RPC is experiencing latency increases across multiple chains and methods in EU region. We're currently investigating the issue.
Affected services
Ethereum
Polygon
Avalanche
Binance
Ethereum Sepolia
Polygon Amoy Testnet
Optimism Sepolia
Arbitrum
Avalanche Fuji
Binance Testnet
Arbitrum Sepolia