Back to overview
Degraded
Degraded performance for Etherlink Mainnet
May 13 at 04:45am PDT
Affected services
Etherlink mainnet
Resolved
May 21 at 05:27am PDT
Degraded performance for Etherlink Mainnet is mitigated.
Affected services
Etherlink mainnet
Created
May 13 at 04:45am PDT
We are experiencing degraded performance for etherlink mainnet. We identified the issue and working on resolving the issue ASAP
Affected services
Etherlink mainnet