Back to overview
Downtime
Geist Mainnet Unavailable
May 23 at 01:37am PDT
Updated
May 28 at 12:19pm PDT
The chain is permanently down.
Affected services
Created
May 23 at 01:37am PDT
Geist Mainnet RPC is not working since the whole chain seems to be down. We are gathering more information to understand how permanent is the issue
Affected services