Back to overview
Downtime

Degraded Transactions performance

Nov 20 at 04:43am PST
Affected services
Transactions (Engine Cloud)

Resolved
Nov 20 at 07:20am PST

We have confirmed full recovery at this time.

Updated
Nov 20 at 07:02am PST

The issue has now been resolved. We sincerely apologize for the inconvenience caused, and we are currently monitoring the system to ensure everything remains stable.

Updated
Nov 20 at 05:11am PST

We’ve identified the root cause and our team is actively working on a fix. Thank you for your patience.

Created
Nov 20 at 04:43am PST

Degraded performance for Transactions. We are investigating the incident.